Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
My '05 Chevrolet cobalt 4 cylnd. Has been puttering badly, acts like it wants to cut off, sometimes it does at a stop. Had engine replaced with '06 engine roundabout a year or so ago. thought maybe bad gas. Put sea foam in it same results. Had test done read code: P0300..misfiring. replaced knock sensor and spark plugs. Same results. Any ideas?


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1957
Images: 37
Location: Oregon
P0300 is not enough information to make a diagnosis. It just tells you what you already know. Your engine is misfiring. You will need to hook up a scanner and look at what the engine is doing. Misfire counter will give you a clue if one cylinder is acting up more than others. Fuel trim will help you see if you're running a lean condition. Exhaust gasses will let you know if you have an injector not letting enough fuel or a coil not firing. (o2 and HC's) Fuel pressure and volume could cause a problem but not usually a missing condition but a good check just in case.

do you have the 2.0L or the 2.2L engine? 2.2 engines can have a problem with coil, just like the quad4's did, where it will short out a couple cylinders. (2.0 will have COP so not so much) You would be able to see the effect with the misfire counter on the scanner. Two cylinders will misfire more that the others.

has the engine been running fine since you installed the 06 motor and just recently started to run badly or have you had a slight problem that has gotten worse? How many miles is on the replacement motor? there are issues with timing chains on some 2.2L. you may want to verify your timing all matches up.


   
Reply with quote  
 
User avatar

contributions: 319
Images: 4
cobalt1217 wrote:
My '05 Chevrolet cobalt 4 cylnd. Has been puttering badly, acts like it wants to cut off, sometimes it does at a stop. Had engine replaced with '06 engine roundabout a year or so ago. thought maybe bad gas. Put sea foam in it same results. Had test done read code: P0300..misfiring. replaced knock sensor and spark plugs. Same results. Any ideas?

You may also have a problem with the cylinder head and valves. See this link for information on
Chevy Cobalt P0300 at Idle


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Truck cuts on and off while driving

in Chevy Silverado

Breanne85

1

1488

Mon Oct 27, 2014 12:31 am

carriedi View the latest

New Articles View the first 2003 Tahoe engine cuts off

in Chevy Trucks

Schebes

7

1679

Thu Aug 07, 2014 10:54 pm

carriedi View the latest

New Articles View the first 2003 chevrolet impala

in Chevy Cars

pinetree

3

1537

Fri Apr 21, 2017 12:31 am

Guest View the latest

New Articles View the first Attachment(s) Chevrolet Trailblazer won't crank to start

in Chevy Trailblazer

devten71

3

1095

Sun Aug 28, 2016 10:28 am

carriedi View the latest

New Articles View the first 1995 chevrolet silverado z71 dies out

in Chevy Silverado

Tacklebox

3

1326

Wed Dec 30, 2015 4:00 pm

carriedi View the latest

New Articles View the first 2007 Chevrolet avalanche 5.3 L V8 Truck Transmission

in Chevy Avalanche

Mrblaster

1

431

Sun Apr 17, 2016 1:40 pm

carriedi View the latest

New Articles View the first 2002 Chevrolet Venture WB Edition No video on DVD screen

in Chevy Venture Van

chevymom2

2

561

Tue Sep 23, 2014 7:16 pm

chevymom2 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us