Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
Hi all,

I recently purchased a 2004 Chevy Impala 3.4L base with 68k miles on it and I am having a problem with the acceleration and coolant level.

About every other time I start the vehicle, the car accelerates on its own, to the point where I am riding the brake when driving on a level road. When the car is engaged in park, it seems to be idling high. Also, when the car does accelerate on its own, I can hear a high-pitched whistling coming from the engine.

The coolant level has been under the cold mark for the last few days. I have added approx. 1.5-2 quarts of Dex-cool. Today it stayed at the cold line and did not require more fluid. I was alerted to the problem because I could hear liquid flowing sounds coming from the dash.

Any advice on what I should do? I have brought it back to the dealer and he has been willing to work with me, but he was not able to replicate the acceleration problem.
The dealer did tell me that the lower intake gasket had been replaced recently. I took apart the air intake and cleaned the throttle body and the IAC, but it hasn't helped.

Thanks for any advice.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1990
Images: 37
Location: Oregon
the high pitch whistling sounds like there may be a vacuum leak somewhere. Unmetered air would cause the oxygen sensor to see a lean condition so the pcm would increase the pulse width to bring the exhaust readings up. You may want to get a scanner and drive the vehicle and graph the readings of the fuel trim, O2 pre-cat sensors, TPS, maf, map, and TAC. See what is happening while the condition is happening. It this something that happens all the time or just intermittently? If it does look like a vacuum problem you could use a smoke machine to find the leak. You may want to check for pending codes or mode 6 information to diag. for this problem. There have been problems with random acceleration from dirty throttle bodies holding the TPS up. (ie. 26-29 when normal would be 14-19)


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 06 impala 3.5

in Chevy Cars

Jeremy

1

196

Sat Apr 29, 2017 1:02 am

carriedi View the latest

New Articles View the first 06 impala 3.5

in Chevy Cars

Jeremy

1

169

Sat Apr 29, 2017 12:54 am

carriedi View the latest

New Articles View the first 06 impala dont do nothing and the key won come off

in Chevy Cars

tururu

5

1718

Thu Aug 18, 2016 6:36 pm

carriedi View the latest

New Articles View the first 2003 chevrolet impala

in Chevy Cars

pinetree

3

1619

Fri Apr 21, 2017 12:31 am

Guest View the latest

New Articles View the first 2003 chevy impala

in Chevy Cars

1121misty

1

1754

Wed Sep 03, 2014 1:26 am

carriedi View the latest

New Articles View the first 2001 chevy impala

in Chevy Cars

daisha

1

1665

Sat Nov 08, 2014 6:33 pm

carriedi View the latest

New Articles View the first Chevy Impala Won't Crank Over

in Chevy Cars

capricebb

1

397

Wed Mar 15, 2017 1:13 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us