All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
I have a 2003 Monte Carlo SS 3.8 engine not super charged.
Problem one: Changed the thermostat because I wasn't getting heat in the car and thought it was sticking open. Now, at idle it will go up to normal temperature idling in the driveway. If I drive down the road the temperature gauge drops about 25 degrees and stays there. The thermostat is a 195 degree thermostat but it runs well below that, by about 25 degrees, driving down the road.

Problem two. When the car is at normal temperature sitting idling, if I turn my heater fan on, the air is warm about a minute at most and cools down to about 45 degrees. The temperature control lever works. If I turn the heat down, the air gets colder. If I set it all the way up, I get 45 degree air. The only time I have any heat is by letting it idle to running temp and then it lasts about one minute. Driving down the road when the temperature gauge is down 25 degrees, there is no heat.

Any help greatly appreciated....


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2126
Images: 37
Location: Oregon
no heat from the heater is usually a sign of low coolant. you get air stuck in the heater core, so no heat.

engine running too cold is usually a poor thermostat. and you get a code P0128 for too cold too long.

is this thermostat doing the same thing as the old thermostat?

This is where a thermal imager would come in handy.


   
Reply with quote  
 

contributions: 2
carriedi wrote:
> no heat from the heater is usually a sign of low coolant. you get air
> stuck in the heater core, so no heat.
>
> engine running too cold is usually a poor thermostat. and you get a code
> P0128 for too cold too long.
>
> is this thermostat doing the same thing as the old thermostat?
>
> This is where a thermal imager would come in handy.

Top heater hose is cool to the touch. The bottom one is warm. Top radiator hose is warm to the touch. With the heater fan on 1, it blows warm air constantly. On 2 it turns cool after a few minutes. On 5 it goes from warm to cool in about thirty seconds. The thermostat has been replaced with a new 195 degree thermostat. Engine is about 195 at idle. Driving down the road it fluctuates between 160 and 180. That makes no sense to me...


   
Reply with quote  
 
User avatar

contributions: 2126
Images: 37
Location: Oregon
even 160 to 180 should give you heat from the heater core if it has that temperature going through it. 130 out of the vent will feel hot to your hand. (not burning hot but it will feel like it will heat your car. If you aren't getting hot air from the vent there are a few things to check. The heater hoses to the heater core. are they both hot when the car is all warmed up? can you check their temperature? You could have an air pocket that gets caught in the heater core. you could have a partially plugged heater core. The GM coolant can plug up the heater core if there is air in the system over time.

the heater will always have hotter air coming out at lower speeds. the same goes for air conditioning. it will come out colder at lower fan speeds. It's because at lower speeds the air has more time going through the heater core or evaporator so it can transfer the heat. At higher speeds the air pushes through much faster so it spends less time pushing past the heat or cooling fins.

the next thing is the blend door. is the blend door moving to the correct position. you can scan the hvac system to make sure the blend door is operating correctly. Sometimes the motor will get stuck or lose the position setting. with a good scanner you can check and move the door to see if it is going all the way through it's cycle.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Monte Carlo knocking in the dash

in Chevy Cars

dunnpaul

2

1807

Mon Aug 08, 2016 5:06 pm

Guest View the latest

New Articles View the first 1999 monte carlo engine continues to run after ignition off

in Chevy Cars

redslippers02

1

1388

Sat Aug 29, 2015 11:15 pm

carriedi View the latest

New Articles View the first 1994 Suburban ECM PROM and programming needed

in Chevy Suburban

gotquestions

1

778

Sat Oct 24, 2015 9:12 pm

carriedi View the latest

New Articles View the first 2004 CHEVY SILVERADO GAUGE SEAT HEATER ISSUES

in Chevy Silverado

mikega

1

99

Sat Dec 30, 2017 5:20 am

carriedi View the latest

New Articles View the first 2003 silverado

in Chevy Silverado

timcogan

5

2050

Wed Jun 22, 2016 5:34 am

carriedi View the latest

New Articles View the first 2003 chevrolet impala

in Chevy Cars

pinetree

3

1968

Fri Apr 21, 2017 12:31 am

Guest View the latest

New Articles View the first Attachment(s) 2003 Silverado Leaking

in Chevy Silverado

MrsB

1

538

Sun Jul 16, 2017 10:06 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us