Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
I have a 93 Buick century special 3.3 v6. It has new catalytic convertor,new throttle positioning sensor, new oxygen sensor, new pcv valve. It runs great the gears on dash are 1,2,D no circle around it just causal D when i try to accelerate best way to describe it is feels like its choking itself out. I have to feather the gas to get it going. Before i know it im 35mph before it shifts from 1rst to 2nd after it hits drive its fine if i have to slow down enough to down shift to 1rst it does it all over again i cleaned maf too i asked couple mechanic about my car one said sounds like a bad ecm i checked auto parts store for price they said my cars transmission doesn't run off the ecm a 4 speed does a 3 speed doesn't. The other mechanic said could be shift solenoid or pressure modulator both $30 parts how long does is take to replace a shift solenoid? Or pressure modulator? So i can figure what I'll pay labor for my mechanic to change them he


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1966
Images: 37
Location: Oregon
you should have a mechanic look at your car to see why your engine seems to struggle when accelerating. Drive with a scanner on it and see what the data stream shows. if your transmission has a vacuum modulator for shifting, engine running badly will screw up the vacuum.


   
Reply with quote  
 

contributions: 2
I took it to a couple different mechanicsĀ told it could be a number of things from a bad ecm ,shifting solenoid, or vacuum modulator. If its something i dont need any special tool for like pulling the modulator outta the back of the trans i could probably do that myself i just don't know if theirs any special way or clips that need to come off the old one and be put on the new one i was told if i pull the hose off and fluid comes out the modulator is.bad replace it now i just have to locate it to check it online it says its behind the trans looks like a can going into tranny with a hose on the end the 1mechanic said on my car its under thehood????? I was told by 2 different auto parts stores my cars trans doesnt run off the ecm so i can rule that out hopefully lol


   
Reply with quote  
 
User avatar

contributions: 1966
Images: 37
Location: Oregon
if your vehicle has a vacuum modulator here is a picture of where it would be. It is held in with one bracket. Unbolt and remove the the bracket, then slowly walk out the modulator.


Attachments:
modulator.jpg
modulator.jpg [ 122.31 KiB | Viewed 2829 times ]
   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Car Trouble - 99 Buick Century Limited

in Buick

CountryGirl2

1

1482

Tue Feb 03, 2015 8:18 pm

carriedi View the latest

New Articles View the first Buick Century idling eratically

in Buick

BethsCentury

6

2972

Sat Jan 03, 2015 2:09 am

carriedi View the latest

New Articles View the first Power Steering locked up while driving my 02 Buick Century.

in Buick

Mike84

3

2505

Sat May 23, 2015 1:15 pm

carriedi View the latest

New Articles View the first Buick Lesabre lights problem

in Buick

wmoc

1

1741

Sat Mar 07, 2015 8:04 pm

carriedi View the latest

New Articles View the first 1998 Buick lesabre tranny problem help

in Buick

kc224336

1

1444

Tue Dec 30, 2014 10:31 pm

carriedi View the latest

New Articles View the first Attachment(s) my 99 buick lasabre

in Buick

continental67

2

475

Wed Mar 08, 2017 2:09 am

carriedi View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

459

Wed Oct 19, 2016 10:58 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us