All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
Air will not blow through my vents on my 95 park ave, I have replaced the blower motor and still no air. What could be my problem?


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
when you say no air comes out the vents, do you mean the fan is on and blowing but no air comes out or is the fan not coming on? Do you mean no air blowing out of the vents, or defrost and heater too? Need more info


   
Reply with quote  
 

contributions: 2
carriedi wrote:
when you say no air comes out the vents, do you mean the fan is on and blowing but no air comes out or is the fan not coming on? Do you mean no air blowing out of the vents, or defrost and heater too? Need more info

the fan will not come on at all, but I can feel heat as I drive the car for a distance. as I have stated the blower motor has been replaced. The defrost take a while put it does eventually defrost the wind shield. can you give me some suggestions on this problem?


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
your blower motor only has two big wires going to it. one black and one purple. If you verify that the black wire is ground then you only have to check if you have power on the purple wire at anytime the fan should be on. you could just unplug the blower motor and use the test light between the two leads in the wire harness connector. If it lights up you have a bad blower. If it doesn't light up check your fuses. fuse 5D (25amp), 5A (10amp) in the instrument panel fuse block and fuse 3 (30amp) in the right side underhood fuse panel. those three power the blower. There are also two relays for the blower in a relay panel in the center of the firewall behind the motor. You have a blower resistor for all the lower speeds and a relay for high speed.

when you are driving there will be air that comes into the car through the vent by your wipers for fresh air. It won't be blowing but it will bring some heat into the vehicle while you are moving.


   
Reply with quote  
 

contributions: 1
check your vacuum line/s in engine compartment leading into firewall, had same problem with 95 buick lesabre


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 1994 Buick Park Avenue

in Buick

KaylaAnneKay

2

1623

Sun Dec 06, 2015 9:28 pm

KaylaAnneKay View the latest

New Articles View the first Buick Park Avenue 1999

in Buick

Haydee

1

675

Tue Dec 27, 2016 3:22 am

carriedi View the latest

New Articles View the first 2002 Buick Park Avenue interior lights issue

in Buick

Shiela

1

1767

Fri Nov 07, 2014 8:02 pm

carriedi View the latest

New Articles View the first Attachment(s) 2002 Rendezvous- Shifter slides... Stuck in park.

in Buick

jsand100

3

1824

Sun Feb 21, 2016 9:51 pm

carriedi View the latest

New Articles View the first Attachment(s) my 99 buick lasabre

in Buick

continental67

2

837

Wed Mar 08, 2017 2:09 am

carriedi View the latest

New Articles View the first 95 Buick regal won't start help please

in Buick

jeff88

6

3726

Fri Aug 14, 2015 1:42 pm

amyb View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

813

Wed Oct 19, 2016 10:58 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us