All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
On occasion, upon starting, my 2003 Buick Century will start with a very high idle. Even after driving it for a while it stays on high idle so fast I don't even need to hit the accelerator to go 25 mph. It seems to be happening more frequently in the past week or so.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 665
The most common cause for this symptom is a bad throttle position sensor. What happens is, the spring breaks inside the sensor which basically allows to spin freely, and not register the correct and actual throttle position. This will lead to a high idle, and even higher idle speeds when coasting or cruising, like your foot is on the gas. The sensor is located on the side of throttle body and is pretty easily replaced.

Other things that can cause a high idle would be a stuck idle air control valve, a vacuum leak, etc, but I'd be willing to bet it's a bad TPS.
_______________

GM Dealer Technician For 18+ Years
In the automotive industry for 20+


   
Reply with quote  
 
im having the same problem out of our 03 century. the service engine light came on and the code it spit out said the TPS needed replaced. we've replaced it twice (assumed advance gave me a bad sensor the first time). still having the same issues. i cant see any obvious vacuum leaks. any new advice before i start spending cash?


   
Reply with quote  
 
Site Admin
User avatar

contributions: 173
Images: 17
jmorganwv wrote:
im having the same problem out of our 03 century. the service engine light came on and the code it spit out said the TPS needed replaced. we've replaced it twice (assumed advance gave me a bad sensor the first time). still having the same issues. i cant see any obvious vacuum leaks. any new advice before i start spending cash?

Check for a broken wire at the sensor. Pull on each wire individually. If one stretches, that means the copper inside the colored insulation is broken
_______________

Be Sure To Check The Related Topics below For More Help.
Did You Find Some Great Help? Help Keep Us Free


   
Reply with quote  
 

contributions: 1
Iam having same issue. I was told mas air flow, throttle position, idle air control, and upper intake. All these parts have been replaced as long as new cat( old one plugged up) but still the throttle is high and seems to be hunting


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Buick intermittant high idle and car accelerates on its own

in Buick

Robby

1

2241

Thu Sep 17, 2015 3:48 pm

carriedi View the latest

New Articles View the first Buick Century idling eratically

in Buick

BethsCentury

6

3299

Sat Jan 03, 2015 2:09 am

carriedi View the latest

New Articles View the first Car Trouble - 99 Buick Century Limited

in Buick

CountryGirl2

1

1630

Tue Feb 03, 2015 8:18 pm

carriedi View the latest

New Articles View the first 2003 Buick Rendezvous over heating

in Buick

TSaldana

1

1793

Tue Feb 16, 2016 3:31 am

carriedi View the latest

New Articles View the first 2003 buick regal instrument lights flash,ticking noise

in Buick

Parker2001

2

1723

Sun Feb 19, 2017 4:50 pm

fishmooften View the latest

New Articles View the first how to get a smooth idle

in Buick

SHOOTER

2

1122

Sun Oct 02, 2016 6:12 pm

SHOOTER1 View the latest

New Articles View the first Rough Idle and Knocking

in Buick

RMax

1

611

Fri Feb 24, 2017 11:38 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us