Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
1998 buick regal gs 3.8 supercharged. The transmission started slipping slightly for the last couple weeks mostly when going uphill. It felt a lot like a coil was goIng. It seemed to drive fine otherwise. No shuttering or major slipping. I drove the car for about an hour, stopped for a few min then drove again and my first stop after putting it in drive it just revved freely. Drive and reverse!

If I leave it a while it go's in gear and drives a few seconds then revs but looses drive as if it's in neutral. What does this sound like? Should I bother replacing filter to see if that makes a difference? Money is tight and hope there's something I can do myself!? Thanks in advance for any help in giving any feedback as to what this might be!


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 665
Unfortunately, this is just plain bad news. When the trans is slipping that badly, usually one or more internal parts has failed. If the fluid is dark or smells burned then you can pretty much bet the entire trans is smoked.

This isn't going to be a cheap repair, as you'll basically either be looking at a complete overhaul of the existing transmission, or putting a used trans or new trans in the car so it will drive.
_______________

GM Dealer Technician For 18+ Years
In the automotive industry for 20+


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

500

Wed Oct 19, 2016 10:58 pm

carriedi View the latest

New Articles View the first 95 Buick regal won't start help please

in Buick

jeff88

6

3412

Fri Aug 14, 2015 1:42 pm

amyb View the latest

New Articles View the first 94 buick regal steering column

in Buick

kickboxer2

1

1776

Tue Jul 29, 2014 1:56 am

carriedi View the latest

New Articles View the first Attachment(s) 1999 Buick Regal SES light still on!

in Buick

gianmarko650

1

2126

Sun Jun 22, 2014 5:32 pm

carriedi View the latest

New Articles View the first 03 Buick Regal No tail lights

in Buick

Tampa1234

5

2295

Mon Oct 20, 2014 10:21 am

carriedi View the latest

New Articles View the first 99 Buick Regal fans not kicking in and SES light?

in Buick

gianmarko650

1

1852

Thu Jun 05, 2014 12:32 am

carriedi View the latest

New Articles View the first 2012 Buick Regal noise when accelerating

in Buick

KR5150

1

329

Thu Apr 13, 2017 2:24 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us